Guía de Práctica 07 - Solucionario

Loading.... (view fulltext now)

Loading....

Loading....

Loading....

Loading....

Texto completo

(1)

GUÍA DE PRÁCTICA 07

Instrucciones: Lea detenidamente cada enunciado y desarrolle lo solicitado.

Antes de iniciar la presente guía crear una carpeta en la unidad Alumno con sus apellidos y nombres, Luego guarde este archivo dentro de la misma también con sus apellidos y nombres.

Utilizar el software PseInt para el diseño de los algoritmo

Desarrolle en Pseudocódigo y Diagrama de Flujo los algoritmos para dar solución a:

While (Mientras) - Do While (Repetir)

1.- Realizar un algoritmo que pida una secuencia de números positivos leídos, que acabe con un –1, por ejemplo: 8,5,3,2,4,2,3,6,7,……,-1; y calcule la media aritmética. (Utilice la estructura While)

Proceso MediaAritm

Escribir "Ingrese número: " Leer num

suma<-0 contador<-1

Mientras (num<>-10) Hacer suma<-suma+num contador<-contador+1 Leer num FinMientras Escribir suma/(contador-1) FinProceso

2.- Sabemos que la clave de una cuenta es “continental”, escribir un algoritmo que solicite una clave. Se tiene sólo 3 intentos para acertar, si fallamos los 3 intentos nos mostrara un mensaje indicándonos que hemos agotado esos 3 intentos. Si acertamos la clave, mostrará la clave es correcta y finalizará el programa. (Utilice la estructura While y Si Entonces)

Proceso ClaveUser contador<-0 //interruptor Sección : Asignatura : Computación Docente : Ing. Apellidos : Nombres: Fecha : Duración: 90 min.

(2)

acierto<-Falso

//usamos un interruptor, cuando acertemos, //cambiara y la condición será falsa

Mientras (contador<3 Y acierto=Falso) Hacer //ponemos aquí leer porque con las variables //iniciales entra en el bucle

Escribir "Introduce la clave" Leer clave

Si (clave="continental") Entonces Escribir "La clave es correcta"

//el interruptor cambia cuando acertamos acierto<-Verdadero

FinSi

contador<-contador+1 FinMientras

//Este mensaje solo aparecerá si hemos agotado //todos los intentos y no hemos acertado

Si (contador=3 Y acierto=falso) Entonces Escribir "Ya no tienes más intentos" FinSi

FinProceso

3.- Crear un algoritmo que calcule la raíz cuadrada del número que introduzca el usuario. Si se introduce un número negativo, debe mostrar un mensaje de error y volver a pedirlo tantas veces como sea necesario, hasta que ingrese un número positivo. (Utilice la estructura Do While)

Proceso RaizCuad Repetir

Escribir "Ingrese un número"; Leer x;

Si x < 0 Entonces

Escribir "No puede ser negativo"; FinSi

(3)

Hasta Que x >= 0

Escribir "Su raiz es ", rc(x) FinProceso

For (Para)

4.- Algoritmo que pida dos números, el primero mayor que el segundo e imprima la serie en forma descendente. Ejemplo si ingreso 21 y 16, debe imprimir 21,20,19,18,17,16

Proceso SerieAsc

Escribir "Ingrese primer número: " Leer numMayor

Escribir "Ingrese segundo número (menor que el primero): " Leer numMenor

Para x <- numMayor Hasta numMenor Hacer Escribir x;

FinPara FinProceso

5.- Algoritmo que permite calcular la suma de los N primeros números enteros positivos ingresados por teclado

Proceso SumaNnum

Escribir "Ingrese un número: " Leer num

Para contador<-1 Hasta num Con Paso 1 Hacer suma <- suma + contador

FinPara

(4)

FinProceso

6.- Algoritmo que calcula el promedio de una lista de números ingresados por teclado.

Proceso Promedio

Escribir "Ingrese la cantidad de datos:" Leer n

acum<-0

Para i<-1 Hasta n Hacer

Escribir "Ingrese el dato" , i , ":" Leer dato

acum<-acum+dato FinPara

prom<-acum/n

Escribir "El promedio es: " prom FinProceso

7.- Crear un algoritmo que solicite un número y muestre su tabla de multiplicar del 1 al 10, (tantas veces sea necesario) para salir digitar el número cero.

Proceso TablaMulti Repetir

Escribir "Ingrese un número para mostrar su tabla " Escribir "Para finalizar digite el número cero"

Leer num

Para i<-0 Hasta 10 Con Paso 1 Hacer result=num*i

Escribir num " x " i " = " result Fin Para

Hasta Que num=0

Escribir "Tablas finalizadas" FinProceso

(5)

8.- Escribir el incremento en uno de un número ingresado por teclado que sea menor de 20, el incremento que se muestra debe ser hasta 20. Ejemplo, si digitas 16 debe mostrar: 17, 18, 19, 20

Proceso Incremento

Escribir "Digita un número"; //Muestra en pantalla la instrucción Leer num; //Ingresa la variable 'a' (número menor a 10)

Para num<-num+1 Hasta 20 Con Paso 1 Hacer Escribir num;

FinPara FinProceso

9.- Algoritmo pida el ingreso de dos números (un rango de menor a mayor) y que visualice sólo los números que son múltiplos de 2 y 3 del rango ingresado.

Proceso Ejercicio_

Escribir "Ingrese primer número del rango: " Leer ini

Escribir "Ingrese segundo número del rango (mayor): " Leer fini

Para ini<-1 Hasta fini Con Paso 1

//Así indicamos si un número es múltiplo de 3 y de 2 Si (ini MOD 2=0 Y ini MOD 3=0) Entonces

Escribir ini FinSi

FinPara FinProceso

10.- Algoritmo que muestre tres candidatos presidenciales (opción 1, 2 y 3 respectivamente) y solicite el ingreso de 10 votos. Al final debe mostrar el resultado de votos de cada candidato (si existe un voto no válido debe volver a solicitar)

(6)

Proceso Candidatos

Escribir "ELECCIONES 2016" Escribir "==============="

Escribir "OPCION 1: NUEVO PERU"

Escribir "OPCION 2: PERU NACIONALISTA" Escribir "OPCION 3: FUERZA PERUANA"

Para i<-1 Hasta 10 Hacer

Escribir sin saltar "Voto ", i, ": " Leer voto;

Segun voto Hacer 1: a<-a+1 2: b<-b+1 3: c<-c+1 De Otro Modo

Escribir "OPCION NO VALIDA" i<-i-1

FinSegun FinPara

Escribir "El candidato Nuevo Perú obtuvo: ", a," Votos" Escribir "El candidato Perú Nacionalista obtuvo: ", b," Votos" Escribir "El candidato Fuerza Peruana obtuvo: ", c," Votos" FinProceso

Figure

Actualización...

Referencias

Actualización...

Related subjects :